Forums

Find answers, ask questions, and connect with our
community all around the world.

Home Forum Omnis General Forum Omnis Studio Community macOS no longer starts after "Force Quit"

  • Omnis Studio Community macOS no longer starts after "Force Quit"

    Posted by David G on July 28, 2023 at 1:03 pm

    Hi all,

    I am a new user to Omnis, I tried to create a project and build it for macOS.

    As it was saying “building” for 10 minutes… I decided to “Force Quit” Omnis Studio and since then it refuses to start.

    I have tried to delete the application and re-install it. Delete the preferences with

    defaults read net.omnis.omnisStudio.Dev.11.0

    With no luck. I seed multiple crash files in ~/Library/Application\ Support/Omnis/Omnis\ Studio\ Community\ Edition\ 11/logs/crashes/reports/pending

    OK, after deleting ~/Library/Application\ Support/Omnis, the application started OK

    Regard

    David

    • This discussion was modified 11 months ago by  David G. Reason: formating error
    Andreas Pfeiffer replied 11 months ago 2 Members · 1 Reply
  • 1 Reply
  • Andreas Pfeiffer

    Administrator
    July 31, 2023 at 7:46 am

    Hello David,

    It could be that if you accidentally created some code, i.e. an infinity loop in a $construct that Omnis will just show a spinning wheel, i.e. and seems unresponsive.

    However there are several techniques you can use to come around such a situation.

    By default Omnis Studio 11 will open all libraries that have not been closed the last time when Omnis has been shut down. That said it will then also try to run the library that might have the tricky loop. You can change this in the config.json file that sits inside the Omnis /studio folder in the application support folder. See also: https://www.omnis.net/developers/resources/onlinedocs/Programming/02libsandclasses.html#starting-omnis-with-a-file

    Another way to not run any code in the library is holding down the “option” key when opening the library.

    There is also a keyboard shortcut “Cmnd+Opt+I” that would allow to interrupt code execution in an endless loop. See also https://www.omnis.net/developers/resources/onlinedocs/Programming/04debug.html#keyboard-shortcuts

    I hope this helps.

    Best,

    Andreas

Log in to reply.