Forums

Find answers, ask questions, and connect with our
community all around the world.

Home Forum Forum di Omnis in Italiano Problema di stampa

  • Problema di stampa

    Posted by Ghiara Mimmo on September 17, 2018 at 10:36 am

    Buongiorno
    mi capita con un cliente che quando manda una stampa da Omnis Runtime 8.0.32 con il mio software, dopo non riescie più a stampare se non spegnendo e accendendola stampante.
    L’unica cosa che faccio prima di stampare è mettere il valore della variabile $pagesetupdata a vuoto
    Se non lo faccio poi non stampa dandomi errore di job
    Non risco a capire il problema
    Qualche suggerimneto?
    Grazie
    Mimmo

    Ghiara Mimmo replied 3 years, 9 months ago 2 Members · 2 Replies
  • 2 Replies
  • Dario L.

    Member
    October 3, 2018 at 10:01 am

    Sono un pò in ritardo, ma hai già provato ad impostare $pagesetupdata al valore predefinito, anzichè cancellarla?
    Calculate $cinst.$pagesetupdata (verifica se la notazione usata è corretta) as $root.$prefs.$pagesetupdata
    Oppure un’altra possibile soluzione è quella di impostare direttamente la proprietà $loadpagesetup della classe del report a falso

  • Ghiara Mimmo

    Member
    October 24, 2018 at 4:27 pm

    Grazie
    Provo ma comunque con il cliente in oggetto il problema è sparito cambiando semplicemente il toner
    Cosa centra direte voi? Eppure è così. Il problema in effeti oltre ch a dare job print error a stampe che da altri clienti funzionavano con omnis, stava generando anche problemi con altri programmi. Stampavi da un software e poi se stampavi da un’altro si inchiodava, a volte è sparita addirittura la stammpante dal pannello di controllo.
    Ora tutto ok
    GRazie del suggerimento

Log in to reply.